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Abstract:  The most common method for estimating a Base Flood Elevation (BFE) involves using 
ESRI's ArcMap and HEC-RAS software, but ArcMap software is expensive and may not be 
available to everyone.  This paper describes an alternative method using an open source GIS 
program (Quantum GIS) and software developed by FEMA, USGS, and USACE to estimate a BFE. 
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1. Introduction 
The purpose of this document is to demonstrate how to estimate a Base Flood Elevation (BFE or 
100-year flood elevation) in an Approximate A flood zone.  This is an important step in 
procuring insurance in the National Flood Insurance Program (NFIP).  The method described is 
appropriate for use on single family residential homes in Approximate A zones with no 
published BFE.  For cases involving commercial, industrial, or multiple family structures it may 
be better to use a more detailed methodology such as a HEC-RAS study by a professional 
engineer.  The method described in this document can be used by local floodplain managers or 
surveyors to complete Elevation Certificates.  Once a person is familiar with the process, it can 
be completed in approximately one hour. 

2. Required Software 

2.1.  Quantum GIS 
Quantum GIS (QGIS) is an open source geographic information system program comparable to 
ESRI's ArcMap software.  While it may not be as commonly used as ArcMap, it is a good 
alternative especially for the budget conscious user.  It can be downloaded from www.qgis.org.  
This manual was developed using version 1.8.0, nicknamed Lisboa.  On the download page, 
download the standalone windows installer to install the software. 

2.2.  QGIS Plugins 
Once you have installed QGIS, open the program by clicking on the Quantum GIS Desktop icon 
on desktop or start menu.  One of the menu items at the top is a Plugin menu.  Click on this and 
then click "Fetch Python Plugins".  Find the "Profile Tool" and install that plugin.  Next find the 
OpenLayers plugin and the Transparency plugin and install those. 

2.3. National Stream Statistics Program 
The NSS program was developed by the USGS and can be downloaded from 
http://water.usgs.gov/software/NSS/.  This manual was developed using NSS version 6.0.   

2.4.  FEMA Quick-2 Program 
The FEMA Quick-2 program was developed by FEMA for estimated BFEs in approximate A 
zones.  You can download the program at 
http://www.fema.gov/library/viewRecord.do?id=2316 or by searching for "FEMA Quick 2".  This 
manual was developed using version 2.0. 

 

 

http://water.usgs.gov/software/NSS/
http://www.fema.gov/library/viewRecord.do?id=2316
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2.5.  HEC-RAS Program 
HEC-RAS is developed by the United States Army Corps of Engineers (USACE) Hydraulic Engineering 
Center (HEC).  It is available for download at http://www.hec.usace.army.mil/software/hec-ras/  This 
manual was developed using HEC-RAS 4.1. 

3. Obtaining Required Data 
To perform a BFE analysis you will need 
terrain data and a layer of stream 
catchments or watersheds.  In addition, 
stream lines and aerial imagery are 
useful but not required. 

3.1.  Terrain Data 
Terrain data is best obtained from the 
National Map Viewer at 
http://viewer.nationalmap.gov/viewer/.  
Navigate the map using the mouse 
wheel to zoom in.  Find the location of 
the structure you want to evaluate and 
zoom to about 1:10,000.  Above the 
map image you will see the blue 
Download Data button with a white 
arrow inside it.  Select "Click here to download by current map extent".  Check the elevation 
box and click next.  You want 1/9 arc second data in the GeoTIFF format, the next best would be 
1/3 arc second data.  Check the box next to your data and click next.  Click Checkout and enter 
your email address.  You will be emailed a link to download the data.  Then unzip the file by 
right clicking and selecting extract all or unzip. 

3.2.  Flow Accumulation Grid 
A flow accumulation grid can be downloaded from the WVFMA website at 
www.wvfma.org/resources/gis. 

3.3. Catchments, Watersheds, and Stream Layers 
These can all be downloaded from the WVFMA website at www.wvfma.org.  A catchment is 
basically a very small watershed. 

 

4. GIS Processing in QGIS 

http://www.hec.usace.army.mil/software/hec-ras/
http://viewer.nationalmap.gov/viewer/
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4.1.  Creating a map and adding data 
Open the Quantum GIS Desktop program.  Click on the Add Raster 
Layer button.  Find the .tif terrain file that you downloaded and 
unzipped.  When added it will just be a gray square.  Now click on the 
Plugins menu, go the OpenLayers Plugin Menu, and add the Google 
Hybrid layer.  It will come in on top of the terrain layer, so in the Layers 
list on the upper left side of the program grab the terrain layer and move it above the Goggle 
Hybrid layer. 

4.2. Converting the terrain from meters to feet 
The terrain data you downloaded is in meters 
and needs to be converted to feet.  Click on 
the Raster menu at the top and select Raster 
Calculator.  Click on the button just to the 
right of the "Output layer" box and select a 
save directory and file name," terrain-ft" is a 
good name.  Next click on the Current Layer 
Extent box to make sure the extent is set.  
Now double click the file name under Raster 
Bands, click the * sign, and type 3.2808 after 
the * sign.  Then click OK.  Now select the 
original terrain layer in the Layer list on the 
left, right click on it and select Remove to 
remove it from the map.  Right click on the terrain-ft layer and select Properties.  The first tab is 
Style and there is a Color map dropdown that is set to Grayscale change this to Psuedocolor and 
click OK.  Now the terrain should actually look terrain.  Right click on terrain-ft again, go to 
Properties, and click on the Transparency tab (this requires the transparency plugin to be 
installed).  Move the Global Transparency slider to about 50% and click OK.  Now you map 
should look something like the picture below.  While the terrain layer doesn’t cover much, we 
only need enough to do one cross section at the structure. 
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At this point you should save the 
map project by clicking on 
File>Save Project As.   

You can use the Identify 
Features button (white mouse 
pointer with a blue i next to it) to 
click on the terrain and see what 
the elevation is at a specific 
point. 

 

 

4.3. Changing the Data 
Frame Coordinate 
System to a 
Projection in Feet 

To get a proper cross section profile for use in Quick-2 the x units need to be in feet, not 
meters.  To do this open the Settings menu at the top and select Project Properties.  Select a 
projected coordinate system in with (ftUS) in the title.  A good choice is standard NAD83 state 
plane systems.  You can type the EPSG number in the filter to select one easily and then click 
OK. 

NAD83/West Virginia North (ftUS) EPSG:26853 

NAD83/West Virginia South (ftUS) EPSG:26854 

NAD83/Ohio North (ftUS)  EPSG:3734 

NAD83/Ohio South (ftUS)  EPSG:3735 

4.4.  Creating a Cross Section Profile 
Once you have a terrain layer in vertical feet and a coordinate system projection in horizontal 
feet you can create a cross section profile. 

The first step is to determine where to place the cross section.  Cross sections should be parallel 
to the stream flow, should intersect the upstream end of the structure in question, and should 
tie into high ground on both sides.  It is also important to draw the cross section from left to 
right if you were looking downstream.   
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To create the cross section zoom 
to the correct area, click on the 
terrain layer to select it, and then 
click on the Plugins menu and 
select the Profile Tool>Terrain 
profile (if you don't see it, make 
sure it has been installed via 
fetch plugins).  Click once to start 
the line.  Single clicks will just 
insert a vertex, a double click will 
end the line.  Once you double 
click you should have a terrain 
profile graph similar to the 
picture at the left.  Open the 
Table tab to get the x-y point 
values and select "Copy to 
clipboard". 

Now open up a blank Excel file and hit CTRL+V to paste the data in the first cell.  These are the 
x-y points of your cross section.  Now that you have this set of data you need to identify where 
the stream is and where the banks are.  Usually the stream is the lowest point on the cross 
section and the banks are the two adjacent points.  Bank points should be at similar elevation 
values.  You can use the map and the measuring tool to help identify the stream 
and bank points.  Once you have done this, make a note of those values in the 
excel sheet.  If you drew from left to right looking downstream, the first bank point in the list 
should be the left bank point. 

Tip:  You can right click on a layer and select "Zoom to Layer Extent" to see an entire layer. 

The x-y values of the cross section profile must be entered into Quick-2 by hand.  With this in 
mind, you may not need to enter every single point, especially if the slopes are steady and 
constant.  Values in between points will be interpolated, so as long as you capture the elevation 
changes you may be able to eliminate typing in some points.  If you choose to do this, mark the 
points you want to use on the excel sheet.  If the terrain change is steady, you may just opt to 
use every other point for your analysis.  Congratulations, you now have a cross section profile! 

 Note: If you plan to use HEC-RAS, you will need additional cross sections upstream and 
downstream and you will need to measure how far upstream and downstream those cross 
sections are so HEC-RAS can estimate the slope.  If you plan to use Quick-2, you just need the 
one cross section and a value for the slope as described in the next section. 
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4.5.  Estimating the Stream Slope 
The Quick-2 program requires the stream slope as an input.  To estimate the stream slope we 
can look at the drop in stream elevation over a 100 foot section.  First go to the Settings > 
Options > Map Tools tab. In the Measure Tool section under Preferred measurement units 
select the feet radio button.  Select the measuring tool and measure from the point where you 
first cross section crossed the stream to a point 100 feet upstream.  Now select the Profile Tool 
Plugin and draw a cross section across that point on the stream, double clicking to finish it.  This 
only needs to cover the stream 
itself.  Select the Table tab and 
look for the lowest value, this will 
be the elevation of the stream at 
that point.  Compare this value 
with the lowest point on the cross 
section already developed at the 
structure.   

In the examples, the upstream 
value is 966.968 while the value 
from the structure cross section 
was 966.157.  So over the course 
of 100 feet the stream dropped 
0.81 feet.  The slope is the rise 
over the run, or 0.81 divided by 100, meaning the slope is 0.0081. 

4.6.  Determining the Drainage Area 
The National Stream Statistics (NSS) program requires the drainage area in square miles to 
estimate what the 1% chance (100-year) stream flow is at a given point.  QGIS and a flow 
accumulation grid can be used to estimate this area.   
 
A flow accumulation grid for the state of West 
Virginia can be downloaded from the West Virginia 
Floodplain Management Association (WVFMA) 
website at http://wvfma.org/resources/gis/.  Once 
the zip file has been downloaded unzip it with WinZip 
or 7zip (or any other compression tool).  Use the Add 
Raster Layer tool to add the facwv.txt text file.  If you 
receive a python error mentioning "transparency" 
you can ignore that, it is just the transparency plugin.  

http://wvfma.org/resources/gis/
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Once it is added, right click on the file and select properties.  On the Style tab, set the Color 
Map to Colormap, and then go to the Colormap tab.  At the bottom of the tab under Generate 
new color map, set the number of entries to two, and then hit the Classify button.  On the list 
that appears, change the first value from 0.000 to 10 and then double click the first color bar 
and change the color to white.  Next go to the Transparency tab and set the slider bar over to 
50 or 60.  Hit OK to accept the properties. 

The result should be a transparent layer with purple lines where all of the streams are.  The 
flow accumulation grid is based on 
a relatively large grid, so the 
accuracy may not be very accurate 
at low scales.  Use the Identify 
Features tool to click on a 
purple/red grid cell next to your 
target location.  Make sure the 
Flow Accumulation Grid is 
selected/highlighted on the layer 
list.  Once you click on a cell a 
Results window will appear with a 
value for Band 1.  In the above 
picture example the value is 

36,126.  This is the number of grid cells with flow that contributes to this location.  Each grid 
cell is 0.00034749 square miles.  So multiplying the two numbers together gives a result of 
12.55 square miles for this drainage area.   

5. Running the NSS Program 
The National Stream Statistics (NSS) program 
from USGS can be downloaded from 
http://water.usgs.gov/software/NSS/.  Once it 
is installed, open the NSS Program (NSS.exe).  
Select the correct state.  Underneath the Rural 
section click on New.  Select a Peak Flow region; 
to figure out which one to select, check the map 
at the end of this document.  Almost all of West 
Virginia is in Crippen & Bue flood region 4, but 
there is a map button to check. 

In the yellow box, type in the square miles of the drainage 

http://water.usgs.gov/software/NSS/
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area and hit enter.  For the Crippen and Bue flood region, click on the Map button.  Almost all 
of West Virginia is in Crippen & Bue flood region 4.  Click OK.  The PK100 value is the peak 100-
year flow.  This value can be used for the 100-year stream flow in HEC-RAS or Quick-2. 

6. Estimating a BFE with the 
Quick-2 Program 

Open the Quick-2 program and create a 
new study (File>New).  Once you have 
the new study, click on the Method 
menu and navigate to Normal Depth > 
Irregular. The menu should look like 
the figure to the right.  For additional 
help, see the Normal Depth Irregular 
Cross Section Tutorial (Example 2) in 
the help menu of the program which 
walks you through a computation. 

In the Cross Section box type “1.1” for your first cross section.  Now open the Excel file that you 
exported the cross section plot into.  Type in the station and elevation numbers, hitting “enter” 
after each entry.  Remember, you do not have to type in every single point but you do need to 
capture all of the significant elevation change points.  Be sure to get the beginning, end, stream 
banks, and channel center in addition to any points where the elevation slope seems to change.  
It may help to look at the profile plot to pick the points, but try to get them at least every 15-20 
feet.  Once you are done hit the Save Points button. 

Next enter the slope, which is feet vertical divided by feet horizontal.  So if it drops 4 feet over a 
500 foot distance, the slope is 4/500=0.008.  On channel bank you select the stations of the left 
and right bank (this is always looking downstream).  For Manning’s N’s see the chart in the Help 
menu, usually the banks are higher values than the channel.  Be conservative here.  Next enter 
the PK100 discharge from the NSS program.  Hit Compute.  The WS Elev is the BFE (round up to 
the next whole foot to account for uncertainty).  Take a screenshot, record the value, and hit 
File > Close/Save. 

7. Estimating a BFE with HEC-RAS 
Quick-2 is adequate for estimating a BFE using 
a single cross section.  But HEC-RAS can also 
be used to estimate BFE with minimal data.  To 
run HEC-RAS the user needs an upstream and 
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downstream cross section in addition to the cross section at the structure.  These can either be 
obtained from the terrain profile or they can be copied from the center cross section and 
modified based on stream slope. 

7.1.  Setting up a HEC-RAS Study 
Open HEC-RAS and in the main window click on File, then New Project.  In the New Project Window type 
in a title and click OK; you will end up back in the main window.  Under the Edit menu you will need to 
enter Geometric Data and Steady Flow Data.  Start by opening the Geometric Data window. 

In the Geometric Data window, click on the River Reach button.  The cursor will become a pencil.  Draw 
a line representing the stream in the direction of upstream to downstream with the north direction 

being up.  You don’t have to be exact here; in fact 
it can be a simple straight line.  Double click to 
end the line and enter the river name and reach 
name at the prompt.  

7.2.  Adding Cross Sections to 
HEC-RAS 
In the Geometric Data window, click on the cross 
section button.  When the Cross Section Data 
window opens, click the Options button and 
select “Add a new cross section.”  It will ask for 

the number of cross sections to be entered; 
just add one for now.  The river station 
asked for is the location on the river.  For 
simplicity, place the cross section of the 
structure at zero.  Then downstream 
sections can be negative numbers and 
upstream sections positive numbers.   

Next enter the station and elevation values 
for the cross section, station being the 
horizontal distance in feet along the cross 
section.  Next enter the downstream reach 
lengths which are the distance from this 
cross section to the next cross section.  If the channel is curved the LOB and ROB (left and right 
overbank) values would be different, but for a simple BFE calculation in an Approximate A zone you can 
use the same values and assume a straight channel.  Manning’s N values can be found in the chart at the 
end of this document.  You must also enter in the bank stations, meaning the horizontal X-value of the 
right and left banks (always looking downstream).  Use the default contraction and expansion 
coefficients of 0.3 and 0.5.  Hit the “Apply Data” button when finished. 
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To enter the additional cross sections you can either add new cross sections or copy the existing cross 
section.  To add a new cross section, click on Options and then Add New Cross Section from the cross 
section data window.  The River Station should be set to the distance up or downstream from the center 
cross section.  For example, a cross section 100 feet downstream would be at station -100 if the center 
section was at station 0.  If you only have one cross section profile to enter, you can copy that cross 
section and use the slope to modify it.  For example, if you know that 100 feet upstream the stream 
channel is 2 feet higher, than you can copy the cross section and put it at station 100.  Then you can 
select Options > Adjust Elevations and add 2 feet to all of the elevation values.  Create a downstream 
copy and make a similar adjustment, subtracting from the elevation values.  You need to have a total of 
three cross sections: one at the structure, one upstream, and one downstream.  Once finished you can 
close the cross section data window and save and close the Geometry Data window. 

7.3.  Defining Steady Flow Data 
In the main menu click on Edit and choose Steady Flow Data.  Enter “1” to create a profile for the 100-
year flow.  Make sure the upstream cross section is selected and enter the CFS for the 100-year flow 
(the PK100 from NSS) under the PF 1 column.  Next click on Reach Boundary Conditions and click on 
Normal Depth.  

 

Enter 0.0001 for the upstream/downstream slope conditions and save the flow data. 

7.4.  Running HEC-RAS and Viewing Output 
In the main menu, click on 
Run then choose Steady 
Flow Analysis.  In the 
Steady Flow Analysis menu 
choose File>New Plan.  
Enter a title for the plan 
and a “short” title (they can 
be the same).  Click on 
compute and then save and 
close the plan.  If you get any errors, try to address them and re-compute. 
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To view the output, go to the main menu window and choose View>Profile Summary Table.  The W.S. 
Elev value is the 100-year water surface elevation at each cross section. 

8. Documentation and Mapping 
To create a map of that flood elevation you can just change the symbology classification on the 
terrain grid.  Right click on the layer, go to properties, and the style tab.  Change the Color map 
dropdown to Colormap.  Go to the Colormap tab.  At the bottom select two for the number of 
entries and hit classify.  Now change the second number to the BFE calculated in Quick-2.  
Double click the first color to change it to white (bottom right color) and the second color to 
red.  You may also want to change the transparency on the Transparency tab.  When finished, 
click OK.  You should now have a map of the inundation in red.  Remember, this map will only 
be accurate for the immediate area along 
the cross section, not up or downstream.  
As you can see in the map on the right, any 
area downstream or upstream of the cross 
section is not accurate because they have 
different BFE's. 

Include the following data in a letter 
document to submit with an elevation 
certificate:  the estimated BFE, the drainage 
area, NSS Crippen & Bue Flood Region, NSS 
state region, PK100 value from NSS, terrain 
data source, software programs used, stream slope, a map, and Manning’s N values. 
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9. Attachments/Resources 

9.1.  West Virginia Stream Flow Regions for NSS 
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9.2. Manning's N Value Descriptions 
Type of channel and description     Min    Normal  Max  
    
 D-1. Minor streams (top width at flood stage <100 ft)     
  a. Streams on plain     
 
    1. Clean, straight, full stage, no rifts or deep pods  0.025 0.030 0.033  
    2. Same as above, but more stones and weeds   0.030 0.035 0.040  
    3. Clean, winding, some pools and shoals   0.033 0.040 0.045  
    4. Same as above, but some weeds and stones   0.035 0.045 0.050  
    5. Same as above, lower stages, ineffective areas  0.040 0.048 0.055  
    6. Same as 4, but more stones     0.045 0.050 0.060  
    7. Sluggish reaches, weedy, deep pools   0.050 0.070 0.080  
    8. Very weedy reaches, timber and underbrush  0.075 0.100 0.150  
 
  b. Mountain streams, no veg in channel, banks steep, brush submerged     
    1. Bottom:  gravels, cobbles, and few boulders   0.030 0.040 0.050  
    2. Bottom:  cobbles with large boulders   0.040 0.050 0.070  
 
 D-2. Floodplains     
  a. Pasture, no brush      
    1. Short grass       0.025 0.030 0.035  
    2. High grass       0.030 0.035 0.050  
  b. Cultivated areas     
    1. No crop       0.020 0.030 0.040  
    2. Mature row crops      0.025 0.035 0.045  
 
    3. Mature field crops      0.030 0.040 0.050  
  c.  Brush     
    1. Scattered brush, heavy weeds    0.035 0.050 0.070  
    2. Light brush and trees, in winter    0.035 0.050 0.060  
    3. Light brush and trees, in summer    0.040 0.060 0.080  
    4. Medium to dense brush, in winter    0.045 0.070 0.110  
    5. Medium to dense brush, in summer    0.070 0.100 0.160  
  d. Trees     
    1. Dense willows, summer, straight    0.110 0.150 0.200  
    2. Cleared land with tree stumps, no sprouts   0.030 0.040 0.050  
 
    3. Same as above, with heavy growth of sprouts  0.050 0.060 0.080  
    4. Heavy timber, few down trees, little undergrwth  0.080 0.100 0.120  
    5. Same as above, with flood stage below branches  0.100 0.120 0.160  
 
 D-3. Major streams (top width at flood stage >100 ft).     
  a. Regular section with no boulders or brush   0.025 . . . . . 0.060  
  b. Irregular and rough section     0.035 . . . . . 0.100 
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